[titanium]JustPuzzle

justPuzzle_ICON好長好長的一段時間,光是遊戲的動畫製作跟插畫的發注管理,就把我的時間榨的乾乾淨淨,不要說去參加不定期的使用者分享會,不翻翻BLOG,連自己有多久沒有打開TITANIUM來看看它有什摩改變都不知道了。剛好趁著這兩天有一點在等素材的空檔就打開來瞧瞧,才注意到他的版本已經排到從v3.1了!!但究竟有甚麼不同,就稍微做個簡單的小APP來試試看吧~

為了想要在有限的時間中快速的完成一個簡單的app,所以構想是還是採用webview的方式來做主軸,加上一點點原生的平台來包裝。平台部分當然是由TITANIUM來製作,webview的部份就用enchant.js的前人作品「コンボパズル」來當藍圖。外觀就用大約10年前的flash版justblog的素材來完成(再次謝謝老橘子艾倫的設計^^")。

實作後,就變成這個樣子:
justPUZZLE
開頭的出場跟當時用flash做的動態一樣,太空艙打開後就是webview的視窗。再把コンボパズル換上一層安迪太空衣,也還算是有模有樣了~
繼續閱讀

[TITANIUM]Your app contains non-public API usage!?

Your app contains non-public API usage...這幾天收到admob的付款單,才想起一年多前最後一次更新的[神仙我知道]v1.2。然後再把它下載回來(嗯…沒錯,我刪掉很久了~)回味一下,發現因為公司前陣子把aws重新整合了一下,結果不知道誰動到我的設定,[神仙我知道]v1.2已經無法更新資料庫,也聊天室也無法使用了。再加上當時連IPHONE5的影子都沒有,當然就沒有想到有一天iphone的螢幕會改變尺寸,還是稍微利用假日的時間來稍稍微更新一下,才對得起admob的付款單阿~
誰知就在一切準備就緒,準備上傳到apple store時,卻出現了這個錯誤:

「Your app contains non-public API usage…..」

疑?我被沒有多加上什麼奇怪的api存取的動作阿?
繼續閱讀

[Titanium]安裝的錯誤

一個好不容易在納期當天趕出來的案子,因為客戶本身沒有安裝好相同的titanium開發環境而又再拖了好幾天。後來才知道,現在的alloy似乎還無法支援node.js的1.0以上的版本,所以才會在新安裝的電腦上一直無法把我完成的程式重新在客戶的開發環境中重新包裝出來!
查詢node.js版本使用:

node -v

如果不是是用的版本,可以用

sudo npm rm npm -g

來解除安裝,然後到node.js版本列表中下載安裝。
繼續閱讀